Posted by stylesen

For Subversion:

../configure --prefix=/home/stylesen/subversion-dev/builds/pure-trunk-neon\ --enable-maintainer-mode --with-ssl --with-neon=/usr/local/neon-0.xx.x \ --with-apxs=/usr/bin/apxs2 --disable-mod-activation \ --with-jdk=/usr/lib/jvm/java-6-openjdk --enable-javahl \ --with-junit=/usr/share/java/junit- \ --with-sqlite=/usr/local/sqlite-3.5.9 --with-apr=/usr/local/apr-1.3.3 \ --with-apr-util=/usr/local/apr-util-1.3.4

For apache:

./configure --prefix=/usr/local/httpd-2.2.9 --enable-ssl --enable-dav=shared\ --enable-dav-fs=shared --enable-dav-lock=shared --enable-rewrite=shared \ --with-apr=/usr/local/apr-1.3.3 --with-apr-util=/usr/local/apr-util-1.3.4

For BDB:

Posted by stylesen

I have an external hard disk which is formatted in ntfs. I enabled ntfs-3g support in Debian etch box using some backport ntfs-3g deb files which was pretty old. Whenever I do a 'mount -t ntfs-3g blah blah' it gives a warning saying that ntfs partition is in use and try mounting with '-o force' option. I neglected the warning and mounted using force several times. Also used the hard disk in my ubuntu box where when I tried copying or rsyncing between folders at times it says some I/O error and failed copying/stating some files. It kept on increasing and lots of files in my hard disk got corrupted.

Posted by stylesen

Today I loaded my laptop with Ubuntu 8.04 LTS version which comes along with Firefox version 3.0b5. As soon as I installed I tried hitting http://www.google.com but I got an error which was like an error we used to see when the internet connection is not working. So I checked all my network connections my wireless connection but in vain. Tried rebooting which also did not help. After which I tried to read the error closely which said "Firefox is working in offline mode".

Then immediately I went to Edit -> Preferences and searched through the option to enable the online mode, but couldn't find one. At last after going through all the menu Items found the menu item to enable online mode here File -> Work Offline

Posted by stylesen

Thanks to krish (mukt.in) who gave me a hint on playing dos games inside a GNU/Linux box. Now am able to play Dangerous Dave in my Debian Etch box with the help of 'dosbox'.

I ve played this game in my 6th standard in the school computer labs. This was the first game which attracted me, and still today am very fond of this game. Some of the other games I would love to play are Prince of Persia, Pacman. But I don't want to use 'Doze' for playing these games. 'dosbox' is the best alternative, to play these games I guess.

See a screenshot in the attachment.

Posted by stylesen
As said by 'peterS' (Peter Samuelson) in #svn-dev irc list to 'nemo'
sudo apt-get install build-essential devscripts fakeroot;
sudo apt-get build-dep subversion;
mkdir /tmp/foo; cd /tmp/foo;
apt-get source subversion; cd subversion-*/;
DEB_BUILD_OPTIONS=nostrip,debug debuild -uc -b
Posted by stylesen
While we build neon 0.27.2 in Debian Etch with ssl support we get the following error message and the configure script fails.
checking for library containing RSA_new... not found
configure: error: could not find library containing RSA_new
In order to overcome this install the following:
$ sudo apt-get install libssl-dev
The above will install all the development headers of ssl and we can use "--with-ssl" in the configure script to build neon. Some of the packages needed to build neon in Debian etch are:
$ sudo apt-get install build-essential libxml2-dev libssl-dev zlib1g-dev
Posted by stylesen
It is really cool to use your Sony Ericsson w700i mobile as a remote control for your laptop powered by Ubuntu Gutsy Gibbon. It is very simple, using this feature you can take control of your presentation, media player, desktop. Sounds cool right? All you have to do is this. Turn on bluetooth in your mobile phone. Now try the following:
Step 1: $ hcitool scan
        Scanning ...
                    00:21:32:45:71:3E       Stylesen

Step 2: $ sudo hidd --connect 00:21:32:45:71:3E

After step 2, you will be asked whether to allow connection from your laptop. If you 
press "yes" then you will be shown a screen "Remote Control" in your mobile which will